]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.0.9-9
[nfs-utils.git] / debian / rules
index 250a13bd6409ce93e5a14ad345beb1e2d4b157d4..f3532ed877ad86f8d1dad63f78af42d50a10e308 100755 (executable)
@@ -3,16 +3,23 @@
 
 export DH_VERBOSE=1
 
+DEB_BUILD_GNU_TYPE     := $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_GNU_TYPE      := $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_ARCH          := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+DEB_HOST_ARCH_OS       := $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+
 # Temporary root
 DEBTMP := $(shell pwd)/debian/tmp
 
 build: build-stamp
 build-stamp:
        dh_testdir
-       ./configure \
+ifeq ($(DEB_HOST_ARCH),ia64)
+       patch -p1 < debian/bzero.patch
+endif
+       CFLAGS="-g -Wall" ./configure \
                --mandir='$${prefix}/share/man' \
-               --enable-secure-statd \
-               --enable-mount
+               --enable-secure-statd 
        $(MAKE)
        touch build-stamp