nfs-utils: reverse order of librpcsecgss and libgssglue checks
authorChuck Lever <chuck.lever@oracle.com>
Wed, 15 Apr 2009 16:38:40 +0000 (12:38 -0400)
committerSteve Dickson <steved@redhat.com>
Wed, 15 Apr 2009 16:38:40 +0000 (12:38 -0400)
The check that validates the version of librpcsecgss also needs to
have libgssglue installed.  Without libgssglue, ./configure complains
that it can't find rpcsecgss, even though it's installed.

It also turns out that the error message generated by pkg-config is
more complete than the one we have in aclocal/rpcsec_vers.m4, so just
let those PKG_CHECK_MODULES m4 macros use the default error message.

Signed-off-by: Chuck Lever <chuck.lever@oracle.com>
Signed-off-by: Steve Dickson <steved@redhat.com>
aclocal/rpcsec_vers.m4

index e59c0aa..25902ca 100644 (file)
@@ -1,12 +1,11 @@
 dnl Checks librpcsec version
 AC_DEFUN([AC_RPCSEC_VERSION], [
 
-  dnl TI-RPC replaces librpcsecgss, but we still need libgssglue
+  PKG_CHECK_MODULES([GSSGLUE], [libgssglue >= 0.1])
+
+  dnl TI-RPC replaces librpcsecgss
   if test "$enable_tirpc" = no; then
-    PKG_CHECK_MODULES([RPCSECGSS], [librpcsecgss >= 0.16], ,
-                      [AC_MSG_ERROR([Unable to locate information required to use librpcsecgss.  If you have pkgconfig installed, you might try setting environment variable PKG_CONFIG_PATH to /usr/local/lib/pkgconfig])])
-  else
-    PKG_CHECK_MODULES([GSSGLUE], [libgssglue >= 0.1])
+    PKG_CHECK_MODULES([RPCSECGSS], [librpcsecgss >= 0.16])
   fi
 
 ])dnl