e59c0aa4a8b39ea26fcbed0893938b273940116d
[nfs-utils.git] / aclocal / rpcsec_vers.m4
1 dnl Checks librpcsec version
2 AC_DEFUN([AC_RPCSEC_VERSION], [
3
4   dnl TI-RPC replaces librpcsecgss, but we still need libgssglue
5   if test "$enable_tirpc" = no; then
6     PKG_CHECK_MODULES([RPCSECGSS], [librpcsecgss >= 0.16], ,
7                       [AC_MSG_ERROR([Unable to locate information required to use librpcsecgss.  If you have pkgconfig installed, you might try setting environment variable PKG_CONFIG_PATH to /usr/local/lib/pkgconfig])])
8   else
9     PKG_CHECK_MODULES([GSSGLUE], [libgssglue >= 0.1])
10   fi
11
12 ])dnl