]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - support/export/Makefile.am
libexport.a: Allow client_init() to fail instead of exit
[nfs-utils.git] / support / export / Makefile.am
index 41769faf2f35890a0fccbd05c3fd4a1e07203875..1ea15397c3a99ef76bb3dc906f3fa48ba9342d91 100644 (file)
@@ -1,6 +1,5 @@
 ## Process this file with automake to produce Makefile.in
 
-RPCGEN         = $(top_builddir)/tools/rpcgen/rpcgen
 
 GENFILES_CLNT  = mount_clnt.c
 GENFILES_XDR   = mount_xdr.c
@@ -8,10 +7,7 @@ GENFILES_H     = mount.h
 
 GENFILES       = $(GENFILES_CLNT) $(GENFILES_SVC) $(GENFILES_XDR) $(GENFILES_H)
 
-EXTRA_DIST     = \
-       mount.x \
-       \
-       keys.c
+EXTRA_DIST     = mount.x
 
 noinst_LIBRARIES = libexport.a
 libexport_a_SOURCES = client.c export.c hostname.c nfsctl.c rmtab.c \
@@ -25,8 +21,13 @@ dist-hook:
          rm ${distdir}/$$f; \
        done
 
+if CONFIG_RPCGEN
+RPCGEN         = $(top_builddir)/tools/rpcgen/rpcgen
 $(RPCGEN):
        make -C $(top_srcdir)/tools/rpcgen all
+else
+RPCGEN = @RPCGEN_PATH@
+endif
 
 $(GENFILES_CLNT): %_clnt.c: %.x $(RPCGEN)
        test -f $@ && rm -rf $@ || true
@@ -39,6 +40,7 @@ $(GENFILES_XDR): %_xdr.c: %.x $(RPCGEN)
 $(GENFILES_H): %.h: %.x $(RPCGEN)
        test -f $@ && rm -rf $@ || true
        $(RPCGEN) -h -o $@ $<
+       rm -f $(top_builddir)/support/include/mount.h
        $(LN_S) ../export/mount.h $(top_builddir)/support/include/mount.h
 
 MAINTAINERCLEANFILES = Makefile.in