]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.1.1-4
[nfs-utils.git] / debian / rules
index fe2b273985852ddb2f1587bd75c008e66d9f8c57..dcd8fb4d066843d5d41693119c9cbbb4ef0bdcdb 100755 (executable)
@@ -2,6 +2,8 @@
 
 include /usr/share/quilt/quilt.make
 
+DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+
 # Temporary root
 DEBTMP := $(CURDIR)/debian/tmp
 
@@ -11,8 +13,7 @@ build-stamp:
        CFLAGS="-g -O2 -Wall" ./configure \
                --mandir='$${prefix}/share/man' \
                --enable-secure-statd \
-               --with-tcp-wrappers \
-               --enable-mount
+               --with-tcp-wrappers
        $(MAKE)
        touch build-stamp
 
@@ -21,7 +22,7 @@ clean: unpatch
        dh_testroot
        rm -f build-stamp
        rm -rf $(DEBTMP)
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean
 
 binary-indep: build
@@ -40,9 +41,9 @@ binary-arch: build
        dh_installman
        dh_link
        dh_installchangelogs ChangeLog
-       dh_strip
+       #dh_strip
        dh_compress
-       dh_fixperms
+       dh_fixperms -Xmount.nfs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol