]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.0.7-3
[nfs-utils.git] / debian / rules
index e2bb39c0f020af3b79a02c78594000d1ec133e97..94c635f8253c8bbae0ed7a26f3576bca83c2b3f8 100755 (executable)
@@ -1,8 +1,9 @@
 #!/usr/bin/make -f
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+# Copyright (c) 2005 by Anibal Monsalve Salazar.
 
 # Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+export DH_VERBOSE=1
 
 # You can use gcc 2.7.2 if it's installed,
 #   but I don't think that's necessary any more.
@@ -13,6 +14,13 @@ DEBTMP       := $(shell pwd)/debian/tmp
 
 build: build-stamp
 build-stamp:
+       # Debian source diffs don't reflect removals.
+       # This kludge will suffice until the next upstream version. *sigh*
+       rm -f debian/nfs-common.config          \
+             debian/nfs-common.templates       \
+             debian/nfs-kernel-server.config   \
+             debian/nfs-kernel-server.templates
+
        dh_testdir
        # Add here commands to compile the package.
        $(SETGCC) ./configure \
@@ -39,6 +47,7 @@ binary-arch: build
        dh_testroot
        dh_clean -k
        dh_installdirs
+       dh_install
        # Add here commands to install the files into debian/tmp
        $(MAKE) install_prefix='$(DEBTMP)' install
        dh_movefiles