]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
The configure option name is --with-gssglue, not --with-libgssglue. Fix this, so...
[nfs-utils.git] / debian / rules
index 344bf6ed1f7aaad1fd333cde4ddd9560c5d346fd..757468e95238ef6ad08cbdf8106ba34f3d6cdbb5 100755 (executable)
@@ -1,79 +1,77 @@
-#!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+#! /usr/bin/make -f
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# You can use gcc 2.7.2 if it's installed,
-#   but I don't think that's necessary any more.
-#SETGCC        := CC=$(notdir $(shell which gcc272 gcc 2>/dev/null | sed '1q'))
+# Parsing of DEB_BUILD_OPTIONS flags.
+# Note that nostrip is handled automatically by debhelper.
+CFLAGS := -g -Wall
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+    CFLAGS += -O0
+else
+    CFLAGS += -O2
+endif
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    MAKEFLAGS += -j$(NUMJOBS)
+endif
 
 # Temporary root
-DEBTMP := $(shell pwd)/debian/tmp
+DEBTMP := $(CURDIR)/debian/tmp
 
-build: build-stamp
+build: build-indep build-arch
+build-indep: build-stamp
+build-arch: build-stamp
 build-stamp:
        dh_testdir
-       # Add here commands to compile the package.
-       $(SETGCC) ./configure \
+       dh_autoreconf
+       CFLAGS="$(CFLAGS)" ./configure \
                --mandir='$${prefix}/share/man' \
-               --enable-secure-statd
-       $(MAKE)
+               --enable-nfsv41 \
+               --enable-ipv6 \
+               --enable-libmount-mount \
+               --with-gssglue \
+               --with-tcp-wrappers
+       $(MAKE) $(MAKEFLAGS)
        touch build-stamp
 
 clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp
-       # Add here commands to clean up after the build process.
-       -$(MAKE) distclean
+       rm -rf $(DEBTMP)
+       [ ! -f Makefile ] || $(MAKE) distclean
+       dh_autoreconf_clean
        dh_clean
 
-# Build architecture-independent files here.
 binary-indep: build
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
 binary-arch: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
-       # Add here commands to install the files into debian/tmp
-       $(MAKE) install_prefix='$(DEBTMP)' install
-       dh_movefiles
-       # Fixups Start Here #
-       cd debian && \
-         for f in lockd statd showmount; do \
-           mv tmp/usr/sbin/*$$f nfs-common/sbin; \
-           perl -pi -e "s#/usr(/sbin/(rpc\\.)?$$f)#\$$1#g" \
-               nfs-common/usr/share/man/man8/$$f.8; \
-         done; \
-         rm -f tmp/usr/sbin/*quota*; \
-         rm -f tmp/usr/share/man/man8/*quota*; \
-         rm -rf tmp/var/lib/nfs/*
-       # Fixups End Here #
-       dh_installdocs -A README
-       dh_installexamples
-#      dh_installmenu
-       dh_installinit -n
-#      dh_installcron
-#      dh_installmanpages
-#      dh_undocumented
-       dh_installchangelogs ChangeLog
+       mkdir $(DEBTMP)
+       $(MAKE) DESTDIR='$(DEBTMP)' install
+       dh_installman
+       dh_install -Xman --fail-missing
+       dh_installdocs -A
+       dh_installdocs -pnfs-common debian/README.Debian.nfsv4
+       install -m 0755 debian/nfs-common.init debian/nfs-common/etc/init.d/nfs-common
+       install -m 0755 debian/nfs-kernel-server.init debian/nfs-kernel-server/etc/init.d/nfs-kernel-server
+       install -m 0644 debian/nfs-common.bugcontrol debian/nfs-common/usr/share/bug/nfs-common/control
+       install -m 0755 debian/nfs-common.bugscript debian/nfs-common/usr/share/bug/nfs-common/script
+       install -m 0644 debian/nfs-utils.bugcontrol debian/nfs-common/usr/share/bug/nfs-utils/control
+       install -m 0644 debian/nfs-utils.bugpresubj debian/nfs-common/usr/share/bug/nfs-utils/presubj
+       install -m 0755 debian/nfs-kernel-server.bugscript debian/nfs-kernel-server/usr/share/bug/nfs-kernel-server/script
+       dh_link
+       dh_installchangelogs
+       dh_lintian
        dh_strip
        dh_compress
        dh_fixperms
-       dh_installdebconf
+       chmod u+s debian/nfs-common/sbin/mount.nfs
        dh_installdeb
-#      dh_makeshlibs
        dh_shlibdeps
        dh_gencontrol
-       dh_md5sums
+       dh_md5sums -Xvar/lib
        dh_builddeb
 
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary