]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.0.7-6
[nfs-utils.git] / debian / rules
index 94c635f8253c8bbae0ed7a26f3576bca83c2b3f8..65117040dd3e2c95f421455dcf144632fb1ef024 100755 (executable)
@@ -1,14 +1,8 @@
 #!/usr/bin/make -f
 # Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
-# Copyright (c) 2005 by Anibal Monsalve Salazar.
 
-# Uncomment this to turn on verbose mode.
 export DH_VERBOSE=1
 
-# You can use gcc 2.7.2 if it's installed,
-#   but I don't think that's necessary any more.
-#SETGCC        := CC=$(notdir $(shell which gcc272 gcc 2>/dev/null | sed '1q'))
-
 # Temporary root
 DEBTMP := $(shell pwd)/debian/tmp
 
@@ -16,14 +10,20 @@ build: build-stamp
 build-stamp:
        # Debian source diffs don't reflect removals.
        # This kludge will suffice until the next upstream version. *sigh*
-       rm -f debian/nfs-common.config          \
+       rm -f debian/nfs-common.conffiles       \
+             debian/nfs-common.config          \
+             debian/nfs-common.files           \
              debian/nfs-common.templates       \
+             debian/nfs-kernel-server.conffiles\
              debian/nfs-kernel-server.config   \
-             debian/nfs-kernel-server.templates
+             debian/nfs-kernel-server.templates\
+             debian/nhfsstone.files
 
        dh_testdir
-       # Add here commands to compile the package.
-       $(SETGCC) ./configure \
+       -test -r /usr/share/misc/config.sub && cp -f /usr/share/misc/config.sub config.sub
+       -test -r /usr/share/misc/config.guess && cp -f /usr/share/misc/config.guess config.guess
+       autoconf
+       ./configure \
                --mandir='$${prefix}/share/man' \
                --enable-secure-statd
        $(MAKE)
@@ -33,57 +33,48 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp
+       rm -rf $(DEBTMP)
        # Add here commands to clean up after the build process.
+       -test -r /usr/share/misc/config.sub && rm -f config.sub
+       -test -r /usr/share/misc/config.guess && rm -f config.guess
        -$(MAKE) distclean
+       rm -f config.log configure
        dh_clean
 
-# Build architecture-independent files here.
 binary-indep: build
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
 binary-arch: build
        dh_testdir
        dh_testroot
        dh_clean -k
        dh_installdirs
-       dh_install
+       mkdir $(DEBTMP)
        # Add here commands to install the files into debian/tmp
        $(MAKE) install_prefix='$(DEBTMP)' install
-       dh_movefiles
+       dh_install --sourcedir=debian/tmp
        # Fixups Start Here #
        cd debian && \
          for f in lockd statd showmount; do \
-           mv tmp/usr/sbin/*$$f nfs-common/sbin; \
            perl -pi -e "s#/usr(/sbin/(rpc\\.)?$$f)#\$$1#g" \
-               nfs-common/usr/share/man/man8/$$f.8; \
+               tmp/usr/share/man/man8/$$f.8; \
          done; \
-         rm -f tmp/usr/sbin/*quota*; \
-         rm -f tmp/usr/share/man/man8/*quota*; \
-         rm -rf tmp/var/lib/nfs/*; \
-         cp --preserve=timestamps etc.exports tmp/etc/exports
+         cp --preserve=timestamps etc.exports nfs-kernel-server/etc/exports; \
+         cp --preserve=timestamps idmapd.conf nfs-common/etc/; \
+         cp --preserve=timestamps gssapi_mech.conf nfs-common/etc/; \
        # Fixups End Here #
-       dh_installdocs -A README
+       dh_installdocs -A
        dh_installexamples
-#      dh_installmenu
        dh_installinit -n
-#      dh_installcron
-#      dh_installmanpages
-#      dh_undocumented
+       dh_installman
+       dh_link
        dh_installchangelogs ChangeLog
        dh_strip
        dh_compress
        dh_fixperms
-       dh_installdebconf
        dh_installdeb
-#      dh_makeshlibs
        dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-source diff:                                                                  
-       @echo >&2 'source and diff are obsolete - use dpkg-source -b'; false
-
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary