]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Migrate the rpc_pipefs mount out of /var/lib to /run, to better support /var on NFS.
[nfs-utils.git] / debian / rules
index 69477afbb055d92476d545890f08f2a40adfea5f..204ac7abb44f895199ec539c50b807bd3969f863 100755 (executable)
@@ -2,7 +2,9 @@
 
 # Parsing of DEB_BUILD_OPTIONS flags.
 # Note that nostrip is handled automatically by debhelper.
-CFLAGS := -g -Wall
+CFLAGS := -g -Wall -DPIPEFS_DIR=\\\"/run/rpc_pipefs\\\" \
+               -DGSSD_PIPEFS_DIR=\\\"/run/rpc_pipefs\\\"
+
 ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
     CFLAGS += -O0
 else
@@ -27,6 +29,7 @@ build-stamp:
                --enable-nfsv41 \
                --enable-ipv6 \
                --enable-libmount-mount \
+               --with-gssglue \
                --with-tcp-wrappers
        $(MAKE) $(MAKEFLAGS)
        touch build-stamp