]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.1.2-6
[nfs-utils.git] / debian / rules
index 5a65ec5ccf949a0c8361a25f7caad1c770e3eed4..1386ba1d852008e102e3188c2384b238f273017c 100755 (executable)
@@ -2,7 +2,18 @@
 
 include /usr/share/quilt/quilt.make
 
-DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+# Parsing of DEB_BUILD_OPTIONS flags.
+# Note that nostrip is handled automatically by debhelper.
+CFLAGS := -g -Wall
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+    CFLAGS += -O0
+else
+    CFLAGS += -O2
+endif
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    MAKEFLAGS += -j$(NUMJOBS)
+endif
 
 # Temporary root
 DEBTMP := $(CURDIR)/debian/tmp
@@ -10,11 +21,11 @@ DEBTMP := $(CURDIR)/debian/tmp
 build: patch build-stamp
 build-stamp:
        dh_testdir
-       CFLAGS="-g -O2 -Wall" ./configure \
+       CFLAGS="$(CFLAGS)" ./configure \
                --mandir='$${prefix}/share/man' \
                --enable-secure-statd \
                --with-tcp-wrappers
-       $(MAKE)
+       $(MAKE) $(MAKEFLAGS)
        touch build-stamp
 
 clean: unpatch