Imported Debian patch 1.0.7-10
[nfs-utils.git] / debian / nfs-common.postinst
index 5af4731..8648d03 100755 (executable)
@@ -4,22 +4,18 @@
 
 case "$1" in
     configure)
-       if [ "$2" != "" -a "$2" != "<unknown>" ] \
-          && dpkg --compare-versions "$2" lt "1:1.0-3" \
-          || ( dpkg --compare-versions "$2" ge "1:1.0.1" \
-               && dpkg --compare-versions "$2" lt "1:1.0.2-1" )
-       then
-           update-rc.d -f nfs-common remove >/dev/null 2>&1 || true
-       fi
        update-rc.d nfs-common defaults 21 79 >/dev/null
 
-       # Remove obsolete debconf questions
-       if [ -e /usr/share/debconf/confmodule ]; then
-           . /usr/share/debconf/confmodule
-           db_unregister nfs-common/tcpwrappers-statd || true
-           db_stop
+       if ! getent passwd statd >/dev/null; then
+           adduser --system statd
+       fi
+       if [ "$2" = "" ] || dpkg --compare-versions "$2" lt 1.0.7-10; then
+           chown statd /var/lib/nfs/sm \
+               /var/lib/nfs/sm.bak \
+               /var/lib/nfs/state \
+               /var/lib/nfs/rpc_pipefs
        fi
-       ;;
+    ;;
 esac
 
 act="restart"