]> git.decadent.org.uk Git - dak.git/blobdiff - debian/rules
Merge remote-tracking branch 'jcristau/fix-orig-sig-check'
[dak.git] / debian / rules
index 74c4a05be21a6a63972c6d4bf7c0e41ba20c5af7..0a7139dda3f503b10903693814ce3472514b6b78 100755 (executable)
@@ -1,55 +1,9 @@
 #!/usr/bin/make -f
-# debian/rules file - for Katie (0.0)
-# Based on sample debian/rules file - for GNU Hello (1.3).
-# Copyright 1994,1995 by Ian Jackson.
-# Copyright 1998,1999,2000 James Troup
-# I hereby give you perpetual unlimited permission to copy,
-# modify and relicense this file, provided that you do not remove
-# my name from the file itself.  (I assert my moral right of
-# paternity under the Copyright, Designs and Patents Act 1988.)
-# This file may have to be extensively modified
 
-build:
+%:
+       dh $@
 
-clean:
-       $(checkdir)
-       -rm -rf debian/tmp debian/*~ debian/files* debian/substvars
-
-binary-indep: checkroot
-       $(checkdir)
-       -rm -rf debian/tmp
-       install -d debian/tmp/DEBIAN/
-       install -m 755 debian/prerm debian/postinst debian/tmp/DEBIAN/
-       install -d debian/tmp/usr/bin/
-       install -m 755 katie debian/tmp/usr/bin/da_install
-       install -m 755 jenna debian/tmp/usr/bin/da_mkfilelist
-       install -m 755 heidi debian/tmp/usr/bin/da_tags
-       install -m 755 charisma debian/tmp/usr/bin/da_mkmaintainers
-       install -m 755 neve debian/tmp/usr/bin/da_populate
-       install -m 755 leon debian/tmp/usr/bin/da_clean
-       install -d debian/tmp/usr/share/doc/gnupg/
-       install -m 644 debian/changelog debian/tmp/usr/share/doc/gnupg/changelog.Debian
-       install -m 644 README NEWS THANKS TODO debian/tmp/usr/share/doc/gnupg/
-       install -m 644 ChangeLog debian/tmp/usr/share/doc/gnupg/changelog
-       gzip -9v debian/tmp/usr/share/doc/gnupg/*
-       install -m 644 debian/copyright debian/tmp/usr/share/doc/gnupg/
-       dpkg-gencontrol -isp
-       chown -R root.root debian/tmp
-       chmod -R go=rX debian/tmp
-       dpkg --build debian/tmp ..
-
-binary-arch:
-
-define checkdir
-       test -f katie -a -f debian/rules
-endef
-
-# Below here is fairly generic really
-
-binary:        binary-indep binary-arch
-
-checkroot:
-       $(checkdir)
-       test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot
+override_dh_auto_test:
+ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
+       tests/test_all.py
+endif