Remove inclusion of <boost/shared_ptr.hpp> and build-dependency on Boost
authorBen Hutchings <ben@decadent.org.uk>
Tue, 24 Feb 2009 00:44:47 +0000 (00:44 +0000)
committerBen Hutchings <ben@decadent.org.uk>
Wed, 25 Feb 2009 02:44:59 +0000 (02:44 +0000)
I formerly used boost::shared_ptr<> to keep track of temporary files,
but have not done so since before version 1.0!

ChangeLog
INSTALL
debian/changelog
debian/control
generate_dvd.cpp
generate_dvd.hpp

index 5cb546d..ae1f074 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,10 @@
+videolink (1.2.6) UNRELEASED; urgency=low
+
+  * Remove inclusion of Boost header and build-dependency on Boost as
+    these are no longer used
+
+ -- Ben Hutchings <ben@decadent.org.uk>  Tue, 24 Feb 2009 00:28:21 +0000
+
 videolink (1.2.5) unstable; urgency=low
 
   * Added workaround for XULRunner 1.9's requirement of 16-bit wchar_t
diff --git a/INSTALL b/INSTALL
index e58abec..f550b83 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -4,11 +4,11 @@ Building VideoLink
 VideoLink is written in C++ and requires a recent C++ compiler
 e.g. g++ 3.3.
 
-It requires headers and libraries for Boost, gtkmm, Mozilla or
-XULRunner, and expat.  I am currently building and testing it with
-Boost 1.33, gtkmm 2.8.8, XULRunner 1.8.0.11 and expat 1.95.8.  It may
-well work with earlier or later versions of these, but Mozilla 1.7
-and gtkmm 2.0 and 2.2 are no longer supported.
+It requires headers and libraries for gtkmm, Mozilla or XULRunner, and
+expat.  I am currently building and testing it with gtkmm 2.8.8,
+XULRunner 1.8.0.11 and expat 1.95.8.  It may well work with earlier or
+later versions of these, but Mozilla 1.7 and gtkmm 2.0 and 2.2 are no
+longer supported.
 
 I use Debian Linux and have not yet attempted to build it on other
 systems, but it should work on most modern Unix-like systems.
index c2390d0..dab315d 100644 (file)
@@ -1,3 +1,10 @@
+videolink (1.2.6-1) UNRELEASED; urgency=low
+
+  * New upstream version
+    - Remove unnecessary build-dependency on libboost-dev
+
+ -- Ben Hutchings <ben@decadent.org.uk>  Tue, 24 Feb 2009 00:28:21 +0000
+
 videolink (1.2.5-1) unstable; urgency=low
 
   * New upstream version
index e169d74..e2e42cc 100644 (file)
@@ -2,7 +2,7 @@ Source: videolink
 Maintainer: Ben Hutchings <ben@decadent.org.uk>
 Section: contrib/graphics
 Priority: extra
-Build-Depends: debhelper (>=4), libboost-dev, libgtkmm-2.4-dev, xulrunner-dev, libexpat1-dev
+Build-Depends: debhelper (>=4), libgtkmm-2.4-dev, xulrunner-dev, libexpat1-dev
 Standards-Version: 3.7.2
 
 Package: videolink
index e28659e..4fcad48 100644 (file)
@@ -1,6 +1,7 @@
 // Copyright 2005-8 Ben Hutchings <ben@decadent.org.uk>.
 // See the file "COPYING" for licence details.
 
+#include <cassert>
 #include <cerrno>
 #include <cstring>
 #include <fstream>
index df68775..e1e3e3c 100644 (file)
@@ -7,8 +7,6 @@
 #include <string>
 #include <vector>
 
-#include <boost/shared_ptr.hpp>
-
 #include <glibmm/refptr.h>
 
 #include "geometry.hpp"