gssd: Add configure check for gss_krb5_free_lucid_sec_context().
authorSimo Sorce <simo@redhat.com>
Tue, 2 Apr 2013 18:41:39 +0000 (14:41 -0400)
committerSteve Dickson <steved@redhat.com>
Tue, 2 Apr 2013 19:08:17 +0000 (15:08 -0400)
Signed-off-by: Simo Sorce <simo@redhat.com>
Signed-off-by: GÃnther Deschner <gdeschner@redhat.com>
Signed-off-by: Steve Dickson <steved@redhat.com>
aclocal/kerberos5.m4

index 7574e2d..ef37e28 100644 (file)
@@ -92,6 +92,8 @@ AC_DEFUN([AC_KERBEROS_V5],[
     AC_DEFINE(HAVE_SET_ALLOWABLE_ENCTYPES, 1, [Define this if the Kerberos GSS library supports gss_krb5_set_allowable_enctypes]), ,$KRBLIBS)
   AC_CHECK_LIB($gssapi_lib, gss_krb5_ccache_name,
     AC_DEFINE(HAVE_GSS_KRB5_CCACHE_NAME, 1, [Define this if the Kerberos GSS library supports gss_krb5_ccache_name]), ,$KRBLIBS)
+  AC_CHECK_LIB($gssapi_lib, gss_krb5_free_lucid_sec_context,
+    AC_DEFINE(HAVE_GSS_KRB5_FREE_LUCID_SEC_CONTEXT, 1, [Define this if the Kerberos GSS library supports gss_krb5_free_lucid_sec_context]), ,$KRBLIBS)
 
   dnl Check for newer error message facility
   AC_CHECK_LIB($gssapi_lib, krb5_get_error_message,