Add requirement for newer libgssglue for svcgssd -n option
authorKevin Coffman <kwc@citi.umich.edu>
Thu, 30 Jun 2011 15:13:38 +0000 (11:13 -0400)
committerSteve Dickson <steved@redhat.com>
Thu, 30 Jun 2011 15:13:38 +0000 (11:13 -0400)
SNAFU.  This came to my attention minutes after 1.2.4 was
released...

Changes in commit d6c1b35c require that gss_acquire_cred()
is now called when the "-n" option is used.  This requires an
updated libgssglue which properly handles name GSS_C_NO_NAME
as input to gss_import_name()/gss_acquire_cred().

Add a requirement for the newer version.

Without the newer libgssglue, when svcgssd is started with "-n"
you will see the error message, "ERROR: GSS-API: error in
gss_acquire_cred(): GSS_S_BAD_NAME (An invalid name was supplied)
- Unknown error"

Signed-off-by: Steve Dickson <steved@redhat.com>
aclocal/rpcsec_vers.m4

index 25902ca..8218372 100644 (file)
@@ -1,7 +1,7 @@
 dnl Checks librpcsec version
 AC_DEFUN([AC_RPCSEC_VERSION], [
 
-  PKG_CHECK_MODULES([GSSGLUE], [libgssglue >= 0.1])
+  PKG_CHECK_MODULES([GSSGLUE], [libgssglue >= 0.3])
 
   dnl TI-RPC replaces librpcsecgss
   if test "$enable_tirpc" = no; then