Update krb5 code to use glue routine lucid context functions
authorneilbrown <neilbrown>
Sun, 26 Mar 2006 23:57:00 +0000 (23:57 +0000)
committerneilbrown <neilbrown>
Sun, 26 Mar 2006 23:57:00 +0000 (23:57 +0000)
The gssd code should not know about the glue layer's context structure.
A previous patch added gss_export_lucid_sec_context() and
gss_free_lucid_sec_context() functions to the gssapi glue layer.
Use these functions rather than calling directly to the Kerberos
gssapi code (which requires the Kerberos context handle rather
than the glue's context handle).

ChangeLog

index f281889..9233742 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,13 @@
+2006-03-27 kwc@citi.umich.edu
+       Update krb5 code to use glue routine lucid context functions
+       
+       The gssd code should not know about the glue layer's context structure.
+       A previous patch added gss_export_lucid_sec_context() and
+       gss_free_lucid_sec_context() functions to the gssapi glue layer.
+       Use these functions rather than calling directly to the Kerberos
+       gssapi code (which requires the Kerberos context handle rather
+       than the glue's context handle).
+       
 2006-03-27 Kevin Coffman <kwc@citi.umich.edu>
        Separate out context handling code for MIT Kerberos and SPKM3
        into their own file.