configure.ac: Disabling v4 should not break the gssd build
authorSteve Dickson <steved@redhat.com>
Thu, 8 Nov 2012 21:49:40 +0000 (16:49 -0500)
committerSteve Dickson <steved@redhat.com>
Sun, 11 Nov 2012 23:01:23 +0000 (18:01 -0500)
Signed-off-by: Steve Dickson <steved@redhat.com>
configure.ac

index 399b081..70d6794 100644 (file)
@@ -278,11 +278,6 @@ if test "$enable_nfsv4" = yes; then
        fi
   fi
 
-  dnl librpcsecgss already has a dependency on libgssapi,
-  dnl but we need to make sure we get the right version
-  if test "$enable_gss" = yes; then
-    AC_RPCSEC_VERSION
-  fi
 else
   enable_nfsdcltrack="no"
 fi
@@ -344,6 +339,11 @@ if test "$enable_gss" = yes; then
   dnl Invoked after AC_KERBEROS_V5; AC_LIBRPCSECGSS needs to have KRBLIBS set
   AC_LIBRPCSECGSS
 
+  dnl librpcsecgss already has a dependency on libgssapi,
+  dnl but we need to make sure we get the right version
+  if test "$enable_gss" = yes; then
+    AC_RPCSEC_VERSION
+  fi
 fi
 
 dnl Check for IPv6 support