]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - utils/rquotad/Makefile.am
Add generated files to CLEANFILES in rquotad
[nfs-utils.git] / utils / rquotad / Makefile.am
index 08837939618cea13baa8b065155b5417dc95cf44..dcc15ac9c4aad1c85d140b486ab8136cabb658c6 100644 (file)
@@ -5,6 +5,8 @@ RPCGEN          = $(top_builddir)/tools/rpcgen/rpcgen
 GENFILES_XDR   = rquota_xdr.c
 GENFILES_H     = rquota.h
 
+BUILT_SOURCES  = $(GENFILES_H)
+
 GENFILES       = $(GENFILES_XDR) $(GENFILES_H)
 man8_MANS      = rquotad.man
 
@@ -38,6 +40,8 @@ $(GENFILES_H): %.h: %.x $(RPCGEN)
        test -f $@ && rm -rf $@ || true
        $(RPCGEN) -h -o $@ $<
 
+CLEANFILES = $(GENFILES)
+
 #######################################################################
 # The following allows the current practice of having
 # daemons renamed during the install to include RPCPREFIX