]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - utils/rquotad/Makefile.am
Use 65534 for anon uid/gid rather than -2
[nfs-utils.git] / utils / rquotad / Makefile.am
index b478fadfb659faa2157b4eb3291de34c14974e52..3a45464998c9e893f894fc2d3b00af41c98075b8 100644 (file)
@@ -1,5 +1,13 @@
 ## Process this file with automake to produce Makefile.in
 
+RPCGEN         = $(top_builddir)/tools/rpcgen/rpcgen
+
+GENFILES_XDR   = rquota_xdr.c
+GENFILES_H     = rquota.h
+
+BUILT_SOURCES  = $(GENFILES_H)
+
+GENFILES       = $(GENFILES_XDR) $(GENFILES_H)
 man8_MANS      = rquotad.man
 
 RPCPREFIX      = rpc.
@@ -9,7 +17,7 @@ sbin_PROGRAMS  = rquotad
 EXTRA_DIST = rquota.x $(man8_MANS) NEW README.okir
 
 rquotad_SOURCES = rquota_server.c rquota_svc.c rquota_xdr.c quotactl.c \
-                 hasquota.c mntent.h pathnames.h rquota.h
+                 hasquota.c mntent.h rquota.h
 rquotad_LDADD = ../../support/export/libexport.a \
                ../../support/nfs/libnfs.a \
                ../../support/misc/libmisc.a \
@@ -19,6 +27,19 @@ rquotad_CPPFLAGS = $(AM_CPPFLAGS) $(CPPFLAGS) \
 
 MAINTAINERCLEANFILES = Makefile.in
 
+
+$(RPCGEN):
+       make -C $(top_srcdir)/tools/rpcgen all
+
+$(GENFILES_XDR): %_xdr.c: %.x $(RPCGEN)
+       test -f $@ && rm -rf $@ || true
+       $(RPCGEN) -c -o $@ $<
+
+
+$(GENFILES_H): %.h: %.x $(RPCGEN)
+       test -f $@ && rm -rf $@ || true
+       $(RPCGEN) -h -o $@ $<
+
 #######################################################################
 # The following allows the current practice of having
 # daemons renamed during the install to include RPCPREFIX