]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.2.1-2
[nfs-utils.git] / debian / rules
index 40a2daf4b996a6ae63228b8954427c64e3a7824f..f9a196a45207fde3176537ea88a4d928f1feb8e2 100755 (executable)
@@ -1,33 +1,44 @@
 #! /usr/bin/make -f
 
-include /usr/share/quilt/quilt.make
+# Parsing of DEB_BUILD_OPTIONS flags.
+# Note that nostrip is handled automatically by debhelper.
+CFLAGS := -g -Wall
+ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
+    CFLAGS += -O0
+else
+    CFLAGS += -O2
+endif
+ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    NUMJOBS = $(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
+    MAKEFLAGS += -j$(NUMJOBS)
+endif
 
 # Temporary root
 DEBTMP := $(CURDIR)/debian/tmp
 
-build: patch build-stamp
+build: build-stamp
 build-stamp:
        dh_testdir
-       CFLAGS="-g -O2 -Wall" ./configure \
+       CFLAGS="$(CFLAGS)" ./configure \
                --mandir='$${prefix}/share/man' \
-               --enable-secure-statd \
+               --disable-tirpc \
                --with-tcp-wrappers
-       $(MAKE)
+       $(MAKE) $(MAKEFLAGS)
        touch build-stamp
 
-clean: unpatch
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp
        rm -rf $(DEBTMP)
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean
 
 binary-indep: build
 binary-arch: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
        mkdir $(DEBTMP)
        $(MAKE) DESTDIR='$(DEBTMP)' install
@@ -42,6 +53,7 @@ binary-arch: build
        dh_strip
        dh_compress
        dh_fixperms
+       chmod u+s debian/nfs-common/sbin/mount.nfs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol