]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.2.1-2
[nfs-utils.git] / debian / rules
index 2bd4939551392df9945d1dec60e51c3e91200aa4..f9a196a45207fde3176537ea88a4d928f1feb8e2 100755 (executable)
@@ -1,7 +1,5 @@
 #! /usr/bin/make -f
 
-include /usr/share/quilt/quilt.make
-
 # Parsing of DEB_BUILD_OPTIONS flags.
 # Note that nostrip is handled automatically by debhelper.
 CFLAGS := -g -Wall
@@ -18,16 +16,17 @@ endif
 # Temporary root
 DEBTMP := $(CURDIR)/debian/tmp
 
-build: patch build-stamp
+build: build-stamp
 build-stamp:
        dh_testdir
        CFLAGS="$(CFLAGS)" ./configure \
                --mandir='$${prefix}/share/man' \
+               --disable-tirpc \
                --with-tcp-wrappers
        $(MAKE) $(MAKEFLAGS)
        touch build-stamp
 
-clean: unpatch
+clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp
@@ -39,7 +38,7 @@ binary-indep: build
 binary-arch: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
        mkdir $(DEBTMP)
        $(MAKE) DESTDIR='$(DEBTMP)' install