]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Add option to specify directory to search for credentials cache files
[nfs-utils.git] / debian / rules
index e2bb39c0f020af3b79a02c78594000d1ec133e97..a8e68855bad4a0ff5edfc503e432db0182ac517c 100755 (executable)
@@ -13,6 +13,13 @@ DEBTMP       := $(shell pwd)/debian/tmp
 
 build: build-stamp
 build-stamp:
+       # Debian source diffs don't reflect removals.
+       # This kludge will suffice until the next upstream version. *sigh*
+       rm -f debian/nfs-common.config          \
+             debian/nfs-common.templates       \
+             debian/nfs-kernel-server.config   \
+             debian/nfs-kernel-server.templates
+
        dh_testdir
        # Add here commands to compile the package.
        $(SETGCC) ./configure \
@@ -39,8 +46,9 @@ binary-arch: build
        dh_testroot
        dh_clean -k
        dh_installdirs
+       dh_install
        # Add here commands to install the files into debian/tmp
-       $(MAKE) install_prefix='$(DEBTMP)' install
+       $(MAKE) DESTDIR='$(DEBTMP)' install
        dh_movefiles
        # Fixups Start Here #
        cd debian && \