]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.1.1-3
[nfs-utils.git] / debian / rules
index 877e659bf4b93a852838f4aaeae492d87b0ad28c..81659a45170c0006cb3d3e9acb77c579459f8dbf 100755 (executable)
@@ -2,12 +2,17 @@
 
 include /usr/share/quilt/quilt.make
 
+DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+
 # Temporary root
 DEBTMP := $(CURDIR)/debian/tmp
 
 build: patch build-stamp
 build-stamp:
        dh_testdir
+ifeq ($(DEB_HOST_ARCH),arm)
+       patch -p0 -i debian/major.patch
+endif
        CFLAGS="-g -O2 -Wall" ./configure \
                --mandir='$${prefix}/share/man' \
                --enable-secure-statd \
@@ -20,8 +25,7 @@ clean: unpatch
        dh_testroot
        rm -f build-stamp
        rm -rf $(DEBTMP)
-       -$(MAKE) distclean
-       $(RM) utils/rquotad/rquota.h utils/rquotad/rquota_xdr.c
+       [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean
 
 binary-indep: build
@@ -40,9 +44,9 @@ binary-arch: build
        dh_installman
        dh_link
        dh_installchangelogs ChangeLog
-       dh_strip
+       #dh_strip
        dh_compress
-       dh_fixperms
+       dh_fixperms -Xmount.nfs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol