]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Fix rpc_init so it isn't confused by ssh
[nfs-utils.git] / debian / rules
index 9f46a9c3ebeb4883f97b842a3e65a68694d79b37..74fec5fb01c77973eeef71b1941f27e94f58cf21 100755 (executable)
@@ -13,6 +13,13 @@ DEBTMP       := $(shell pwd)/debian/tmp
 
 build: build-stamp
 build-stamp:
+       # Debian source diffs don't reflect removals.
+       # This kludge will suffice until the next upstream version. *sigh*
+       rm -f debian/nfs-common.config          \
+             debian/nfs-common.templates       \
+             debian/nfs-kernel-server.config   \
+             debian/nfs-kernel-server.templates
+
        dh_testdir
        # Add here commands to compile the package.
        $(SETGCC) ./configure \
@@ -39,30 +46,34 @@ binary-arch: build
        dh_testroot
        dh_clean -k
        dh_installdirs
+       dh_install
        # Add here commands to install the files into debian/tmp
        $(MAKE) install_prefix='$(DEBTMP)' install
        dh_movefiles
        # Fixups Start Here #
        cd debian && \
-         for f in rpc.lockd rpc.statd showmount; do \
-           mv tmp/usr/sbin/$$f nfs-common/sbin/$$f; \
+         for f in lockd statd showmount; do \
+           mv tmp/usr/sbin/*$$f nfs-common/sbin; \
+           perl -pi -e "s#/usr(/sbin/(rpc\\.)?$$f)#\$$1#g" \
+               nfs-common/usr/share/man/man8/$$f.8; \
          done; \
          rm -f tmp/usr/sbin/*quota*; \
          rm -f tmp/usr/share/man/man8/*quota*; \
-         rm -rf tmp/var/lib/nfs/*
+         rm -rf tmp/var/lib/nfs/*; \
+         cp --preserve=timestamps etc.exports tmp/etc/exports
        # Fixups End Here #
-       dh_installdocs ChangeLog README
+       dh_installdocs -A README
        dh_installexamples
 #      dh_installmenu
        dh_installinit -n
 #      dh_installcron
 #      dh_installmanpages
 #      dh_undocumented
-       dh_installchangelogs
+       dh_installchangelogs ChangeLog
        dh_strip
-       dh_suidregister
        dh_compress
        dh_fixperms
+       dh_installdebconf
        dh_installdeb
 #      dh_makeshlibs
        dh_shlibdeps