]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Fix rpc_init so it isn't confused by ssh
[nfs-utils.git] / debian / rules
index 536853119f1124a8b3e6e6b196ff8947138017cd..74fec5fb01c77973eeef71b1941f27e94f58cf21 100755 (executable)
@@ -13,6 +13,13 @@ DEBTMP       := $(shell pwd)/debian/tmp
 
 build: build-stamp
 build-stamp:
+       # Debian source diffs don't reflect removals.
+       # This kludge will suffice until the next upstream version. *sigh*
+       rm -f debian/nfs-common.config          \
+             debian/nfs-common.templates       \
+             debian/nfs-kernel-server.config   \
+             debian/nfs-kernel-server.templates
+
        dh_testdir
        # Add here commands to compile the package.
        $(SETGCC) ./configure \
@@ -39,6 +46,7 @@ binary-arch: build
        dh_testroot
        dh_clean -k
        dh_installdirs
+       dh_install
        # Add here commands to install the files into debian/tmp
        $(MAKE) install_prefix='$(DEBTMP)' install
        dh_movefiles
@@ -51,7 +59,8 @@ binary-arch: build
          done; \
          rm -f tmp/usr/sbin/*quota*; \
          rm -f tmp/usr/share/man/man8/*quota*; \
-         rm -rf tmp/var/lib/nfs/*
+         rm -rf tmp/var/lib/nfs/*; \
+         cp --preserve=timestamps etc.exports tmp/etc/exports
        # Fixups End Here #
        dh_installdocs -A README
        dh_installexamples
@@ -68,9 +77,6 @@ binary-arch: build
        dh_installdeb
 #      dh_makeshlibs
        dh_shlibdeps
-       # Hackery Begins Here #
-       perl -pi -e 's/2\.2\.4-2/2.2.4-1/g' debian/*substvars
-       # Hackery Ends Here #
        dh_gencontrol
        dh_md5sums
        dh_builddeb