]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
Imported Debian patch 1.1.2-5
[nfs-utils.git] / debian / rules
index 663e711c7bd42246de209fecd83df7ea64eee610..5a65ec5ccf949a0c8361a25f7caad1c770e3eed4 100755 (executable)
@@ -2,6 +2,8 @@
 
 include /usr/share/quilt/quilt.make
 
+DEB_HOST_ARCH := $(shell dpkg-architecture -qDEB_HOST_ARCH)
+
 # Temporary root
 DEBTMP := $(CURDIR)/debian/tmp
 
@@ -10,7 +12,8 @@ build-stamp:
        dh_testdir
        CFLAGS="-g -O2 -Wall" ./configure \
                --mandir='$${prefix}/share/man' \
-               --enable-secure-statd 
+               --enable-secure-statd \
+               --with-tcp-wrappers
        $(MAKE)
        touch build-stamp
 
@@ -19,8 +22,7 @@ clean: unpatch
        dh_testroot
        rm -f build-stamp
        rm -rf $(DEBTMP)
-       -$(MAKE) distclean
-       $(RM) utils/rquotad/rquota.h utils/rquotad/rquota_xdr.c
+       [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean
 
 binary-indep: build
@@ -42,6 +44,7 @@ binary-arch: build
        dh_strip
        dh_compress
        dh_fixperms
+       chmod u+s debian/nfs-common/sbin/mount.nfs
        dh_installdeb
        dh_shlibdeps
        dh_gencontrol