]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/rules
mount nfsd filesystem at startup, and unmount afterwards
[nfs-utils.git] / debian / rules
index 344bf6ed1f7aaad1fd333cde4ddd9560c5d346fd..4c8834b9a972912d7581f23fab1e91b3b357b29b 100755 (executable)
@@ -13,6 +13,13 @@ DEBTMP       := $(shell pwd)/debian/tmp
 
 build: build-stamp
 build-stamp:
+       # Debian source diffs don't reflect removals.
+       # This kludge will suffice until the next upstream version. *sigh*
+       rm -f debian/nfs-common.config          \
+             debian/nfs-common.templates       \
+             debian/nfs-kernel-server.config   \
+             debian/nfs-kernel-server.templates
+
        dh_testdir
        # Add here commands to compile the package.
        $(SETGCC) ./configure \
@@ -51,7 +58,8 @@ binary-arch: build
          done; \
          rm -f tmp/usr/sbin/*quota*; \
          rm -f tmp/usr/share/man/man8/*quota*; \
-         rm -rf tmp/var/lib/nfs/*
+         rm -rf tmp/var/lib/nfs/*; \
+         cp --preserve=timestamps etc.exports tmp/etc/exports
        # Fixups End Here #
        dh_installdocs -A README
        dh_installexamples