]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/nfs-common.postinst
* Remove obsolete debconf-related files in debian/rules, because source
[nfs-utils.git] / debian / nfs-common.postinst
index 9814bc5e21a7198b1538690aaff3164f47cf222f..5af4731e87791e704755457a4882f7731bcfb80c 100755 (executable)
@@ -1,17 +1,27 @@
 #!/bin/sh -e
 
+#DEBHELPER#
+
 case "$1" in
     configure)
-       test ! -d /usr/share/doc/nfs-common ||
-         test -L /usr/doc/nfs-common ||
-         ln -sf ../share/doc/nfs-common /usr/doc/nfs-common
-
-       update-rc.d nfs-common defaults 19 81 >/dev/null 2>&1
+       if [ "$2" != "" -a "$2" != "<unknown>" ] \
+          && dpkg --compare-versions "$2" lt "1:1.0-3" \
+          || ( dpkg --compare-versions "$2" ge "1:1.0.1" \
+               && dpkg --compare-versions "$2" lt "1:1.0.2-1" )
+       then
+           update-rc.d -f nfs-common remove >/dev/null 2>&1 || true
+       fi
+       update-rc.d nfs-common defaults 21 79 >/dev/null
 
-       /etc/init.d/nfs-common start
-       ;;
-
-    *)
-       /etc/init.d/nfs-common start
+       # Remove obsolete debconf questions
+       if [ -e /usr/share/debconf/confmodule ]; then
+           . /usr/share/debconf/confmodule
+           db_unregister nfs-common/tcpwrappers-statd || true
+           db_stop
+       fi
        ;;
 esac
+
+act="restart"
+[ "$1:$2" = "configure:" ] && act="start"
+invoke-rc.d nfs-common $act