]> git.decadent.org.uk Git - nfs-utils.git/blobdiff - debian/nfs-common.init
debian/changelog: Version 1.0.5-2.
[nfs-utils.git] / debian / nfs-common.init
index 78edad134214dc75313490e179067785ccb0301d..f6c4a8ad2a3bad07c8019c0b6f7534a440c4f45a 100755 (executable)
@@ -9,22 +9,36 @@
 #             locking functionality.
 #
 
-PREFIX=
+set -e
 
-NEED_LOCKD=yes
-if test -f /proc/ksyms
-then
-    # We need to be conservative and run lockd,
-    # unless we can prove that it isn't required.
-    grep -q lockdctl /proc/ksyms || NEED_LOCKD=no
+# What is this?
+DESC="NFS common utilities"
+
+# Read config
+DEFAULTFILE=/etc/default/nfs-common
+PREFIX=
+NEED_LOCKD=
+if [ -f $DEFAULTFILE ]; then
+    . $DEFAULTFILE
 fi
 
+# Determine whether lockd is required
+case "$NEED_LOCKD" in
+yes|no)        ;;
+*)  # We must be conservative and run lockd,
+    #  unless we can prove that it's not required.
+    NEED_LOCKD=yes
+    if test -f /proc/ksyms
+    then
+       grep -q lockdctl /proc/ksyms || NEED_LOCKD=no
+    fi
+    ;;
+esac
+
+# Exit if required binaries are missing.
 [ -x $PREFIX/sbin/rpc.statd ] || exit 0
 [ -x $PREFIX/sbin/rpc.lockd ] || [ "$NEED_LOCKD" = no ] || exit 0
 
-# What is this?
-DESC="NFS common utilities"
-
 # See how we were called.
 case "$1" in
   start)
@@ -32,12 +46,12 @@ case "$1" in
        printf "Starting $DESC:"
        printf " statd"
        start-stop-daemon --start --quiet \
-           --exec $PREFIX/sbin/rpc.statd
+           --exec $PREFIX/sbin/rpc.statd -- $STATDOPTS
        if [ "$NEED_LOCKD" = yes ]
        then
            printf " lockd"
            start-stop-daemon --start --quiet \
-               --exec $PREFIX/sbin/rpc.lockd
+               --exec $PREFIX/sbin/rpc.lockd  || true
        fi
        echo "."
        ;;
@@ -48,11 +62,11 @@ case "$1" in
        then
            printf " lockd"
            start-stop-daemon --stop --oknodo --quiet \
-               --exec $PREFIX/sbin/rpc.lockd
+               --name rpc.lockd --user 0  || true
        fi
        printf " statd"
        start-stop-daemon --stop --oknodo --quiet \
-           --exec $PREFIX/sbin/rpc.statd
+           --name rpc.statd --user 0
        echo "."
        ;;