Set default hostname to '*' rather than leaving it empty
[nfs-utils.git] / configure.in
index 8cd00df..43c0b46 100644 (file)
@@ -4,7 +4,7 @@ AC_INIT(rules.mk)
 AC_PREFIX_DEFAULT(/usr)
 
 # The nfs-utils version
-VERSION="1.0.7"
+VERSION="1.0.8-rc1"
 AC_SUBST(VERSION)
 
 dnl *************************************************************
@@ -136,6 +136,7 @@ AC_SUBST(LIBWRAP)
 if test "$enable_gss" = yes; then
   dnl 'gss' also depends on nfsidmap.h - at least for svcgssd_proc.c
   AC_CHECK_HEADERS(nfsidmap.h, ,[AC_MSG_ERROR(libnfsidmap needed for gss support)])
+  AC_CHECK_HEADERS(spkm3.h, ,[AC_MSG_WARN(could not locate SPKM3 header; will not have SPKM3 support)])
   
   dnl Checks for Kerberos
   dnl NOTE: while we intend to do generic gss-api, currently we
@@ -223,6 +224,12 @@ if test "$enable_gss" = yes; then
     AC_MSG_WARN(Using $KRBDIR instead of requested value of $krb5_with for Kerberos!)
   fi
 
+  dnl This is not done until here because we need to have KRBLIB set
+  dnl "librpcsecgss=1" is so that it doesn't get added to LIBS
+  AC_CHECK_LIB(rpcsecgss, authgss_create_default, [librpcsecgss=1], [AC_MSG_ERROR(librpcsecgss needed for nfsv4 support)], $KRBLIB)
+  AC_CHECK_LIB(rpcsecgss, authgss_set_debug_level,
+              AC_DEFINE(HAVE_AUTHGSS_SET_DEBUG_LEVEL, 1, [Define this if the rpcsec_gss library has the function authgss_set_debug_level]),, $KRBLIB)
+
   AC_SUBST([KRBDIR])
   AC_SUBST([KRBLIB])
   AC_SUBST([KRBINC])