Understand type 2 and type 3 filesystem identifiers.
[nfs-utils.git] / README
diff --git a/README b/README
index 6c460b4..3fa3a58 100644 (file)
--- a/README
+++ b/README
@@ -1,98 +1,65 @@
-This is the Linux NFS utility package version 0.1.4. It is based on
-knfsd 1.4.7.
+This is version 1.0.1 of nfs-utils, the Linux NFS utility package.
 
-WARNING: The NFS servers in Linux 2.2 to 2.2.13 are not compatible with
-other NFS client implemenations. If you plan to use Linux 2.2.x as an
-NFS server for non-Linux NFS clients, you should get the Linux NFS
-kernel from the Linux NFS CVS server:
 
-1. Set the environment variable, CVS_RSH, to ssh.
-2. Login to the Linux NFS CVS server:
+0. PROJECT RESOURCES
 
-# cvs -z 3 -d:pserver:anonymous@cvs.linuxnfs.sourceforge.org:/cvsroot/nfs login
+Home page:  http://sourceforge.net/projects/nfs/
 
-without password if it is your first time.
+To use the 'gss' support you must have kerberos-5 development 
+libraries installed.
+Otherwise use  "--disable-gss"
 
-3. Check out the current Linux 2.2 NFS kernel:
+To use nfsv4 support you need libevent and libnfsidmap development
+libraries.  They are available from 
+   http://www.monkey.org/~provos/libevent/
+   http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/
+Otherwise use --disable-nfsv4
 
-a. From the NFS V2 branch:
 
-# cvs -z 3 -d:pserver:anonymous@cvs.linuxnfs.sourceforge.org:/cvsroot/nfs co -r linux-2-2-nfsv2 linux-2.2
+1. COMPILING WITHOUT PACKAGE MANAGEMENT
 
-b. From the main trunk:
+To compile without using a package management system, unpack the
+sources and run these commands:
 
-# cvs -z 3 -d:pserver:anonymous@cvs.linuxnfs.sourceforge.org:/cvsroot/nfs co linux-2.2
+    # ./configure
+    # make
 
-4. If you don't want to use the current NFS kernel, you can find out
-for which kernels the NFS patch is available:
+To install binaries and documenation, run this command:
 
-# cd linux-2.2
-# cvs -z 9 -d:pserver:anonymous@cvs.linuxnfs.sourceforge.org:/cvsroot/nfs status -v Makefile
+    # make install
 
-Then generate the kernel patch:
+You will have to install the two NFS service scripts yourself.
+Service scripts for RedHat 6.x and 7.x are in etc/redhat.  They
+have been tested on RedHat 6.2 and 7.1.
 
-# cvs -z 3 -d:pserver:anonymous@cvs.linuxnfs.sourceforge.org:/cvsroot/nfs rdiff -ko -u -r linux-2-2-xx -r linux-2-2-xx-nfsv2-xxxxx linux-2.2
 
-If there is no NFS patch for the kernel you are interested in, you have
-to make a patch closest to your kernel version and apply it by hand.
+2. COMPILING WITH RPM
 
-There is a Linux NFS kernel source tree for Linux 2.3, linux-2.3, on
-the Linux NFS CVS server. We will need all the help we can get. To
-contribute to the Linux NFS project, please go to
+On RedHat 6.2 and 7.1, you can use
 
-http://www.linuxnfs.sourceforge.org
+    # rpm -ta nfs-utils-1.0.1.tar.gz
 
-You register yourself. Please send an email to
-nfs-admin@linuxnfs.sourceforge.org with
-
-1. Your user id on www.linuxnfs.sourceforge.org.
-2. The area in NFS you'd like to work on.
-
-You will be notified when it is done.
-
-There is a Linux NFS mailing list at
-
-http://lists.varesearch.com/lists/listinfo/nfs/
-
-You can subscribe it and search the mailing list archive via a web
-browser.
-
-The nfs-utils package is available from the CVS server:
-
-# cvs -z 3 -d:pserver:anonymous@cvs.linuxnfs.sourceforge.org:/cvsroot/nfs co nfs-utils
-
-will get the latest version.
-
-The files are
-
-ftp://ftp.linuxnfs.sourceforge.org/pub/nfs/nfs-utils-0.1.4.tar.gz
-ftp://ftp.linuxnfs.sourceforge.org/pub/nfs/nfs-utils-0.1.3-0.1.4.diff.gz
-
-To compile, just do
+to build the source and binary RPMs.
 
-# ./configure
-# make
 
-# make install
+3. COMPILING FOR DEBIAN
 
-will install the nfs-utils binaries. You have to install the NFS
-service scripts. There are 2 in etc/redhat provided for RedHat 6.x.
-They are tested on RedHat 6.1.
+The nfs-utils tree has an up-to-date debian directory, so the usual
+debian build scripts should work.  The simplest way to build binary
+debs, however, is simply to become root (or use fakeroot) and run:
 
-On RedHat 6.1, you can use
+    # debian/rules binary
 
-# rpm -ta nfs-utils-0.1.4.tar.gz
 
-to build the source and binary RPMs.
+4. REQUIRED VERSIONS OF OTHER TOOLS
 
-If your mount from util-linux is too old, you will need 2 patches:
+Proper NFS operation requires a 'mount' program from util-linux 2.11f
+or later.
 
-ftp://ftp.linuxnfs.sourceforge.org/pub/nfs/util-linux-2.9o-mount-nfsv3.patch
-ftp://ftp.linuxnfs.sourceforge.org/pub/nfs/util-linux-2.9w-mount-nfsv3try.patch
 
-Thanks.
+Share And Enjoy!
 
+    -- the nfs-utils developers
+       <nfs@lists.sourceforge.net>
+       26 Dec 2001
 
-H.J.
-hjl@lucon.org
-12/06/99