]> git.decadent.org.uk Git - ion3.git/blobdiff - debian/patches/201_build-config.diff
Remove executable permission from patches
[ion3.git] / debian / patches / 201_build-config.diff
old mode 100755 (executable)
new mode 100644 (file)
index c58cdf2..97d2186
@@ -1,5 +1,7 @@
---- ion3.orig/system.mk
-+++ ion3/system.mk
+Index: ion3-20080707/system.mk
+===================================================================
+--- ion3-20080707.orig/system.mk       2008-07-07 16:39:16.000000000 +0100
++++ ion3-20080707/system.mk    2008-07-11 00:31:29.000000000 +0100
 @@ -8,7 +8,7 @@
  
  # Installation path prefix. Unless you know what you're doing, the default
@@ -32,7 +34,7 @@
  # For ion-completeman system-wide cache
  VARDIR=/var/cache/ion3
  # Message catalogs
-@@ -59,18 +59,18 @@
+@@ -62,18 +62,18 @@
  
  # If you have installed Lua 5.1 from the official tarball without changing
  # paths, this should do it.
@@ -60,7 +62,7 @@
  
  
  ##
-@@ -124,7 +124,7 @@
+@@ -127,7 +127,7 @@
  # You may uncomment this if you know that your system C libary provides
  # asprintf and  vasprintf. (GNU libc does.) If HAS_SYSTEM_ASPRINTF is not
  # defined, an implementation provided in libtu/sprintf_2.2/ is used. 
  
  # The following setting is needed with GNU libc for clock_gettime and the
  # monotonic clock. Other systems may not need it, or may not provide a
-@@ -163,14 +163,14 @@
- #C89_SOURCE=-ansi
--#POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
-+POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
+@@ -172,11 +172,11 @@
+ POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
  
  # Most systems
 -#XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
  
  # The -DCF_HAS_VA_COPY option should allow for some optimisations, and 
  # in some cases simply defining
---- ion3.orig/utils/ion-statusd/Makefile
-+++ ion3/utils/ion-statusd/Makefile
-@@ -15,7 +15,7 @@
- DEFINES += -DETCDIR=\"$(ETCDIR)\" -DSHAREDIR=\"$(SHAREDIR)\" \
-            -DEXTRABINDIR=\"$(EXTRABINDIR)\" -DMODULEDIR=\"$(MODULEDIR)\" \
-          -DLCDIR=\"$(LCDIR)\" -DLOCALEDIR=\"$(LOCALEDIR)\" \
--           -DSTATUSD_LOCATION=\"$(EXTRABINDIR)/ion-statusd\"
-+#           -DSTATUSD_LOCATION=\"$(EXTRABINDIR)/ion-statusd\"
-            
- SOURCES = ion-statusd.c exec.c extlrx.c