]> git.decadent.org.uk Git - ion3.git/blobdiff - debian/patches/201_build-config.diff
Remove executable permission from patches
[ion3.git] / debian / patches / 201_build-config.diff
old mode 100755 (executable)
new mode 100644 (file)
index 6a3ce86..97d2186
@@ -1,15 +1,17 @@
---- ion3.orig/system.mk
-+++ ion3/system.mk
-@@ -7,7 +7,7 @@
- ## Installation paths
- ##
+Index: ion3-20080707/system.mk
+===================================================================
+--- ion3-20080707.orig/system.mk       2008-07-07 16:39:16.000000000 +0100
++++ ion3-20080707/system.mk    2008-07-11 00:31:29.000000000 +0100
+@@ -8,7 +8,7 @@
  
+ # Installation path prefix. Unless you know what you're doing, the default
+ # of /usr/local is likely the correct choice.
 -PREFIX=/usr/local
 +PREFIX=/usr
  
  # Unless you are creating a package conforming to some OS's standards, you
  # probably do not want to modify the following directories:
-@@ -15,7 +15,7 @@
+@@ -16,7 +16,7 @@
  # Main binaries
  BINDIR=$(PREFIX)/bin
  # Configuration .lua files
@@ -18,7 +20,7 @@
  # Some .lua files and ion-* shell scripts
  SHAREDIR=$(PREFIX)/share/ion3
  # Manual pages
-@@ -27,11 +27,11 @@
+@@ -28,11 +28,11 @@
  # Nothing at the moment
  LIBDIR=$(PREFIX)/lib
  # Modules
@@ -32,7 +34,7 @@
  # For ion-completeman system-wide cache
  VARDIR=/var/cache/ion3
  # Message catalogs
-@@ -56,18 +56,18 @@
+@@ -62,18 +62,18 @@
  
  # If you have installed Lua 5.1 from the official tarball without changing
  # paths, this should do it.
  
  
  ##
-@@ -104,7 +104,7 @@
- # asprintf and vasprintf in the c library. (gnu libc has.)
- # If HAS_SYSTEM_ASPRINTF is not defined, an implementation
- # in sprintf_2.2/ is used.
+@@ -127,7 +127,7 @@
+ # You may uncomment this if you know that your system C libary provides
+ # asprintf and  vasprintf. (GNU libc does.) If HAS_SYSTEM_ASPRINTF is not
+ # defined, an implementation provided in libtu/sprintf_2.2/ is used. 
 -#HAS_SYSTEM_ASPRINTF=1
 +HAS_SYSTEM_ASPRINTF=1
  
- # If you're on an archaic system (such as relatively recent *BSD releases)
- # without even dummy multibyte/widechar and localisation support, you may 
-@@ -140,14 +140,14 @@
- #C89_SOURCE=-ansi
--#POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
-+POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
+ # The following setting is needed with GNU libc for clock_gettime and the
+ # monotonic clock. Other systems may not need it, or may not provide a
+@@ -172,11 +172,11 @@
+ POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
  
  # Most systems
 -#XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED