]> git.decadent.org.uk Git - ap-utils.git/blobdiff - debian/rules
Remove duplicate
[ap-utils.git] / debian / rules
index 6abb8aab5baee0c0ce1361fb8e4438d8ed578767..93ba26f2e834d8ef5a1e10aaa2dac1df1c8bbb1b 100755 (executable)
@@ -5,16 +5,13 @@ export DH_COMPAT=3
 export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
 export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
 
-# FOR AUTOCONF 2.13 ONLY
-ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
-  confflags += $(DEB_HOST_GNU_TYPE)
-else
-  confflags += --host $(DEB_BUILD_GNU_TYPE) --build $(DEB_HOST_GNU_TYPE)
-endif
+confflags += --host $(DEB_BUILD_GNU_TYPE) --build $(DEB_HOST_GNU_TYPE)
 
 build: build-stamp
 build-stamp:
        dh_testdir
+       cp -f /usr/share/misc/config.sub config.sub
+       cp -f /usr/share/misc/config.guess config.guess
        ./configure $(confflags) --prefix=/usr \
                    --mandir=\$${prefix}/share/man \
                    --infodir=\$${prefix}/share/info
@@ -24,11 +21,7 @@ build-stamp:
 clean:
        dh_testdir
        dh_testroot
-       rm -f build-stamp 
-       -test -r /usr/share/misc/config.sub && \
-          cp -f /usr/share/misc/config.sub config.sub
-       -test -r /usr/share/misc/config.guess && \
-          cp -f /usr/share/misc/config.guess config.guess
+       rm -f build-stamp config.sub config.guess
        -$(MAKE) distclean
        #Really clean the po directory
        dh_clean po/*.gmo