1 # We don't use libtool.
4 Summary: NFS utlilities and supporting daemons for the kernel NFS server.
8 Source0: ftp://nfs.sourceforge.net/pub/nfs/%{name}-%{version}.tar.gz
9 Group: System Environment/Daemons
12 Obsoletes: knfsd-clients
13 Obsoletes: nfs-server-clients
16 Provides: nfs-server-clients
18 Provides: knfsd-clients
21 Buildroot: /var/tmp/%{name}-root
22 Requires: kernel >= 2.2.7, portmap >= 4.0
25 The nfs-utils package provides a daemon for the kernel NFS server and
26 related tools, which provides a much higher level of performance than the
27 traditional Linux NFS server used by most users.
29 This package also contains the showmount program. Showmount queries the
30 mount daemon on a remote host for information about the NFS (Network File
31 System) server on the remote host. For example, showmount can display the
32 clients which are mounted on that host.
42 rm -rf $RPM_BUILD_ROOT
43 mkdir -p $RPM_BUILD_ROOT/{/sbin,/usr/sbin}
44 mkdir -p $RPM_BUILD_ROOT%{_mandir}/{man5,man8}
45 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
46 mkdir -p $RPM_BUILD_ROOT/var/lib/nfs
47 make install_prefix=$RPM_BUILD_ROOT MANDIR=$RPM_BUILD_ROOT%{_mandir} SBINDIR=$RPM_BUILD_ROOT%{_prefix}/sbin install
48 install -s -m 755 tools/rpcdebug/rpcdebug $RPM_BUILD_ROOT/sbin
49 install -m 755 etc/redhat/nfs.init $RPM_BUILD_ROOT/etc/rc.d/init.d/nfs
50 install -m 755 etc/redhat/nfslock.init $RPM_BUILD_ROOT/etc/rc.d/init.d/nfslock
51 touch $RPM_BUILD_ROOT/var/lib/nfs/rmtab
52 mv $RPM_BUILD_ROOT/usr/sbin/{rpc.lockd,rpc.statd} $RPM_BUILD_ROOT/sbin
55 rm -rf $RPM_BUILD_ROOT
58 /sbin/chkconfig --add nfs
59 /sbin/chkconfig --add nfslock
62 if [ "$1" = "0" ]; then
63 /sbin/chkconfig --del nfs
64 /sbin/chkconfig --del nfslock
67 %triggerpostun -- nfs-server
68 /sbin/chkconfig --add nfs
70 %triggerpostun -- knfsd
71 /sbin/chkconfig --add nfs
73 %triggerpostun -- knfsd-clients
74 /sbin/chkconfig --add nfslock
78 %config /etc/rc.d/init.d/nfs
80 %config(noreplace) /var/lib/nfs/xtab
81 %config(noreplace) /var/lib/nfs/etab
82 %config(noreplace) /var/lib/nfs/rmtab
94 %config /etc/rc.d/init.d/nfslock
95 %doc README ChangeLog COPYING