]> git.decadent.org.uk Git - videolink.git/blobdiff - debian/rules
Added entries for 1.1 and 1.1-1.
[videolink.git] / debian / rules
index f5a20beafbc7e9f2e1d4b7bb65f5c37ada5b545f..ff70afd77f0316fe468af1553a9af51fe3e27506 100755 (executable)
@@ -10,9 +10,17 @@ binary-arch : build
        make DESTDIR=debian/videolink prefix=/usr install
        dh_strip
        dh_shlibdeps
-       @echo "Despite the warnings from dh_shlibdeps, this should complete dependencies:"
-       MOZ_VERSION=$$(dpkg-query -W --showformat='$${version}' mozilla-browser | sed 's/+b[0-9]*$$//') \
-       && echo "mozilla:Depends=mozilla-browser (>= $$MOZ_VERSION), mozilla-browser (<= $${MOZ_VERSION}+b99)" >> debian/videolink.substvars
+       # VideoLink relies on some un-frozen APIs which may break
+       # between releases and even with backported security patches.
+       # The libxul packages have sonames and a shlibs file so we
+       # should get correct dependencies automatically, but this is
+       # not the case for mozilla-browser.
+       if dpkg-query -W libxul-dev >&/dev/null; then \
+           echo "mozilla:Depends=" >> debian/videolink.substvars ; \
+       else \
+           MOZ_VERSION=$$(dpkg-query -W --showformat='$${version}' mozilla-browser | sed 's/+b[0-9]*$$//') \
+           && echo "mozilla:Depends=mozilla-browser (>= $$MOZ_VERSION), mozilla-browser (<< $${MOZ_VERSION}+b99)" >> debian/videolink.substvars ; \
+       fi
        mkdir -p -m755 debian/videolink/usr/share/doc/videolink
        install -m644 debian/copyright debian/videolink/usr/share/doc/videolink/copyright
        mv debian/videolink/usr/share/doc/videolink/ChangeLog.gz \
@@ -28,5 +36,6 @@ binary-indep :
 
 clean :
        make clean
+       dh_clean
 
 .PHONY : build binary binary-arch binary-dep clean svn-build