]> git.decadent.org.uk Git - videolink.git/blobdiff - debian/rules
Removed strict version dependency on libxul0d based on an assurances from Mike Hommey...
[videolink.git] / debian / rules
index 3e4825601dee170bd9c15988444cfec110ec7fd6..ff70afd77f0316fe468af1553a9af51fe3e27506 100755 (executable)
@@ -10,13 +10,13 @@ binary-arch : build
        make DESTDIR=debian/videolink prefix=/usr install
        dh_strip
        dh_shlibdeps
-       # VideoLink relies on some "internal" APIs which we cannot trust
-       # Mozilla.org not to break between releases or even with security
-       # patches.  So we add a dependendency on the exact same version
-       # of the library that we're building against.
-       if pkg-config --exists xulrunner-gtkmozembed; then \
-           MOZ_VERSION=$$(dpkg-query -W --showformat='$${version}' libxul0d | sed 's/+b[0-9]*$$//') \
-           && echo "mozilla:Depends=libxul0d (>= $$MOZ_VERSION), libxul0d (<< $${MOZ_VERSION}+b99)" >> debian/videolink.substvars ; \
+       # VideoLink relies on some un-frozen APIs which may break
+       # between releases and even with backported security patches.
+       # The libxul packages have sonames and a shlibs file so we
+       # should get correct dependencies automatically, but this is
+       # not the case for mozilla-browser.
+       if dpkg-query -W libxul-dev >&/dev/null; then \
+           echo "mozilla:Depends=" >> debian/videolink.substvars ; \
        else \
            MOZ_VERSION=$$(dpkg-query -W --showformat='$${version}' mozilla-browser | sed 's/+b[0-9]*$$//') \
            && echo "mozilla:Depends=mozilla-browser (>= $$MOZ_VERSION), mozilla-browser (<< $${MOZ_VERSION}+b99)" >> debian/videolink.substvars ; \