]> git.decadent.org.uk Git - videolink.git/blobdiff - debian/rules
Switched to gtkmm 2.4+ since gtkmm 2.0 is being removed from Debian.
[videolink.git] / debian / rules
index 2bc03aa1c8b469ec07a5328d564e2adcc890ef1d..ff70afd77f0316fe468af1553a9af51fe3e27506 100755 (executable)
@@ -10,9 +10,13 @@ binary-arch : build
        make DESTDIR=debian/videolink prefix=/usr install
        dh_strip
        dh_shlibdeps
-       if pkg-config --exists xulrunner-gtkmozembed; then \
-           MOZ_VERSION=$$(dpkg-query -W --showformat='$${version}' xulrunner | sed 's/+b[0-9]*$$//') \
-           && echo "mozilla:Depends=xulrunner (>= $$MOZ_VERSION), xulrunner (<< $${MOZ_VERSION}a)" >> debian/videolink.substvars ; \
+       # VideoLink relies on some un-frozen APIs which may break
+       # between releases and even with backported security patches.
+       # The libxul packages have sonames and a shlibs file so we
+       # should get correct dependencies automatically, but this is
+       # not the case for mozilla-browser.
+       if dpkg-query -W libxul-dev >&/dev/null; then \
+           echo "mozilla:Depends=" >> debian/videolink.substvars ; \
        else \
            MOZ_VERSION=$$(dpkg-query -W --showformat='$${version}' mozilla-browser | sed 's/+b[0-9]*$$//') \
            && echo "mozilla:Depends=mozilla-browser (>= $$MOZ_VERSION), mozilla-browser (<< $${MOZ_VERSION}+b99)" >> debian/videolink.substvars ; \
@@ -32,5 +36,6 @@ binary-indep :
 
 clean :
        make clean
+       dh_clean
 
 .PHONY : build binary binary-arch binary-dep clean svn-build