]> git.decadent.org.uk Git - videolink.git/blobdiff - debian/rules
Corrected shared library dependencies when building with XULRunner (I hope).
[videolink.git] / debian / rules
index 2bc03aa1c8b469ec07a5328d564e2adcc890ef1d..3e4825601dee170bd9c15988444cfec110ec7fd6 100755 (executable)
@@ -10,9 +10,13 @@ binary-arch : build
        make DESTDIR=debian/videolink prefix=/usr install
        dh_strip
        dh_shlibdeps
+       # VideoLink relies on some "internal" APIs which we cannot trust
+       # Mozilla.org not to break between releases or even with security
+       # patches.  So we add a dependendency on the exact same version
+       # of the library that we're building against.
        if pkg-config --exists xulrunner-gtkmozembed; then \
-           MOZ_VERSION=$$(dpkg-query -W --showformat='$${version}' xulrunner | sed 's/+b[0-9]*$$//') \
-           && echo "mozilla:Depends=xulrunner (>= $$MOZ_VERSION), xulrunner (<< $${MOZ_VERSION}a)" >> debian/videolink.substvars ; \
+           MOZ_VERSION=$$(dpkg-query -W --showformat='$${version}' libxul0d | sed 's/+b[0-9]*$$//') \
+           && echo "mozilla:Depends=libxul0d (>= $$MOZ_VERSION), libxul0d (<< $${MOZ_VERSION}+b99)" >> debian/videolink.substvars ; \
        else \
            MOZ_VERSION=$$(dpkg-query -W --showformat='$${version}' mozilla-browser | sed 's/+b[0-9]*$$//') \
            && echo "mozilla:Depends=mozilla-browser (>= $$MOZ_VERSION), mozilla-browser (<< $${MOZ_VERSION}+b99)" >> debian/videolink.substvars ; \
@@ -32,5 +36,6 @@ binary-indep :
 
 clean :
        make clean
+       dh_clean
 
 .PHONY : build binary binary-arch binary-dep clean svn-build