]> git.decadent.org.uk Git - maypole.git/blobdiff - debian/rules
Added README.Debian explaining use with Debian Apache/mod_perl packages.
[maypole.git] / debian / rules
index 2fd9adf8ef525c2983388601a55524566e973b1c..8352dba04263041c9877aa3db37fa0e45d8c2ce5 100755 (executable)
@@ -1,8 +1,10 @@
 #!/usr/bin/make -f
 
+include /usr/share/quilt/quilt.make
+
 build : build-stamp
 
-build-stamp : Makefile.PL
+build-stamp : Makefile.PL $(QUILT_STAMPFN)
        perl Makefile.PL INSTALLDIRS=vendor
        $(MAKE) test
        touch build-stamp
@@ -15,15 +17,25 @@ binary-indep : build-stamp
        dh_testroot
        $(MAKE) PREFIX=$(CURDIR)/debian/libmaypole-perl/usr install
        dh_perl
-       dh_installchangelogs
+       dh_installchangelogs Changes
        dh_installdocs
-       dh_compress
+       mv debian/libmaypole-perl/usr/share/perl5/Maypole/templates \
+           debian/libmaypole-perl/usr/share/doc/libmaypole-perl/templates
+       mkdir debian/libmaypole-perl/usr/share/doc/libmaypole-perl/ex/templates
+       mv debian/libmaypole-perl/usr/share/doc/libmaypole-perl/templates/beer \
+          debian/libmaypole-perl/usr/share/doc/libmaypole-perl/ex/templates/custom
+       ln -s ../../templates/factory \
+          debian/libmaypole-perl/usr/share/doc/libmaypole-perl/ex/templates/factory
+       ln -s ../../../templates/factory \
+          debian/libmaypole-perl/usr/share/doc/libmaypole-perl/ex/fancy_example/templates/factory
+       dh_compress -X/ex/ -X/templates/
        dh_fixperms
        dh_gencontrol
+       dh_md5sums
        dh_builddeb
 
-clean : 
+clean : unpatch
        if [ -f Makefile ]; then $(MAKE) clean; fi
        dh_clean Makefile Makefile.old build-stamp
 
-.PHONY : build binary binary-arch binary-dep clean
+.PHONY : build binary binary-arch binary-dep clean patch unpatch