]> git.decadent.org.uk Git - maypole.git/blobdiff - debian/rules
Added patch to fix some inconsistencies between examples and tutorial.
[maypole.git] / debian / rules
index e763e3fb77d5af5b9d300792bc897ea935c688f3..7c2d11b5c040402897a96a3e583bb71c6e63b217 100755 (executable)
@@ -1,8 +1,10 @@
 #!/usr/bin/make -f
 
+include /usr/share/quilt/quilt.make
+
 build : build-stamp
 
-build-stamp : Makefile.PL
+build-stamp : Makefile.PL $(QUILT_STAMPFN)
        perl Makefile.PL INSTALLDIRS=vendor
        $(MAKE) test
        touch build-stamp
@@ -20,10 +22,11 @@ binary-indep : build-stamp
        dh_compress
        dh_fixperms
        dh_gencontrol
+       dh_md5sums
        dh_builddeb
 
-clean : 
+clean : unpatch
        if [ -f Makefile ]; then $(MAKE) clean; fi
        dh_clean Makefile Makefile.old build-stamp
 
-.PHONY : build binary binary-arch binary-dep clean
+.PHONY : build binary binary-arch binary-dep clean patch unpatch