]> git.decadent.org.uk Git - maypole.git/blobdiff - debian/rules
Started using quilt.
[maypole.git] / debian / rules
index 2fd9adf8ef525c2983388601a55524566e973b1c..7c2d11b5c040402897a96a3e583bb71c6e63b217 100755 (executable)
@@ -1,8 +1,10 @@
 #!/usr/bin/make -f
 
+include /usr/share/quilt/quilt.make
+
 build : build-stamp
 
-build-stamp : Makefile.PL
+build-stamp : Makefile.PL $(QUILT_STAMPFN)
        perl Makefile.PL INSTALLDIRS=vendor
        $(MAKE) test
        touch build-stamp
@@ -15,15 +17,16 @@ binary-indep : build-stamp
        dh_testroot
        $(MAKE) PREFIX=$(CURDIR)/debian/libmaypole-perl/usr install
        dh_perl
-       dh_installchangelogs
+       dh_installchangelogs Changes
        dh_installdocs
        dh_compress
        dh_fixperms
        dh_gencontrol
+       dh_md5sums
        dh_builddeb
 
-clean : 
+clean : unpatch
        if [ -f Makefile ]; then $(MAKE) clean; fi
        dh_clean Makefile Makefile.old build-stamp
 
-.PHONY : build binary binary-arch binary-dep clean
+.PHONY : build binary binary-arch binary-dep clean patch unpatch