]> git.decadent.org.uk Git - maypole.git/blobdiff - debian/rules
Updated patches for 2.13.
[maypole.git] / debian / rules
index b263d502c30d41a5236bf8b8ccc1da849f273277..4f80aaa59ebdaa8b9286f8dc6cbd754510eac42a 100755 (executable)
@@ -1,8 +1,10 @@
 #!/usr/bin/make -f
 
+include /usr/share/quilt/quilt.make
+
 build : build-stamp
 
-build-stamp : Makefile.PL
+build-stamp : Makefile.PL $(QUILT_STAMPFN)
        perl Makefile.PL INSTALLDIRS=vendor
        $(MAKE) test
        touch build-stamp
@@ -17,14 +19,23 @@ binary-indep : build-stamp
        dh_perl
        dh_installchangelogs Changes
        dh_installdocs
-       dh_compress
+       mv debian/libmaypole-perl/usr/share/perl5/Maypole/templates \
+           debian/libmaypole-perl/usr/share/doc/libmaypole-perl/templates
+       mkdir debian/libmaypole-perl/usr/share/doc/libmaypole-perl/examples/templates
+       mv debian/libmaypole-perl/usr/share/doc/libmaypole-perl/templates/beer \
+          debian/libmaypole-perl/usr/share/doc/libmaypole-perl/examples/templates/custom
+       ln -s ../../templates/factory \
+          debian/libmaypole-perl/usr/share/doc/libmaypole-perl/examples/templates/factory
+       ln -s ../../../templates/factory \
+          debian/libmaypole-perl/usr/share/doc/libmaypole-perl/examples/fancy_example/templates/factory
+       dh_compress -X/examples/ -X/templates/
        dh_fixperms
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-clean : 
+clean : unpatch
        if [ -f Makefile ]; then $(MAKE) clean; fi
        dh_clean Makefile Makefile.old build-stamp
 
-.PHONY : build binary binary-arch binary-dep clean
+.PHONY : build binary binary-arch binary-dep clean patch unpatch