]> git.decadent.org.uk Git - maypole.git/blobdiff - debian/rules
Updated patches for 2.13.
[maypole.git] / debian / rules
old mode 100644 (file)
new mode 100755 (executable)
index 864a189..4f80aaa
@@ -1,28 +1,41 @@
 #!/usr/bin/make -f
 
-build :
+include /usr/share/quilt/quilt.make
+
+build : build-stamp
+
+build-stamp : Makefile.PL $(QUILT_STAMPFN)
        perl Makefile.PL INSTALLDIRS=vendor
-       $(MAKE)
+       $(MAKE) test
+       touch build-stamp
 
 binary : binary-arch binary-indep
 
 binary-arch :
 
-binary-indep : build
+binary-indep : build-stamp
        dh_testroot
-       mkdir -p -m755 debian/libmaypole-perl/usr/share/perl5
        $(MAKE) PREFIX=$(CURDIR)/debian/libmaypole-perl/usr install
        dh_perl
-       mkdir -p -m755 debian/libmaypole-perl/usr/share/doc/libmaypole-perl
-       dh_installchangelogs
+       dh_installchangelogs Changes
        dh_installdocs
-       dh_compress
+       mv debian/libmaypole-perl/usr/share/perl5/Maypole/templates \
+           debian/libmaypole-perl/usr/share/doc/libmaypole-perl/templates
+       mkdir debian/libmaypole-perl/usr/share/doc/libmaypole-perl/examples/templates
+       mv debian/libmaypole-perl/usr/share/doc/libmaypole-perl/templates/beer \
+          debian/libmaypole-perl/usr/share/doc/libmaypole-perl/examples/templates/custom
+       ln -s ../../templates/factory \
+          debian/libmaypole-perl/usr/share/doc/libmaypole-perl/examples/templates/factory
+       ln -s ../../../templates/factory \
+          debian/libmaypole-perl/usr/share/doc/libmaypole-perl/examples/fancy_example/templates/factory
+       dh_compress -X/examples/ -X/templates/
        dh_fixperms
        dh_gencontrol
+       dh_md5sums
        dh_builddeb
 
-clean : 
+clean : unpatch
        if [ -f Makefile ]; then $(MAKE) clean; fi
-       dh_clean Makefile
+       dh_clean Makefile Makefile.old build-stamp
 
-.PHONY : build binary binary-arch binary-dep clean
+.PHONY : build binary binary-arch binary-dep clean patch unpatch