]> git.decadent.org.uk Git - ion3.git/blobdiff - debian/patches/201_build-config.diff
Updated debian/copyright file for ion-3rc-20080103.
[ion3.git] / debian / patches / 201_build-config.diff
index 6a3ce869a196cd11137be878e49f3dfdd2fa3695..c58cdf2c8c08e6806102886619d01218a288585c 100755 (executable)
@@ -1,15 +1,15 @@
 --- ion3.orig/system.mk
 +++ ion3/system.mk
-@@ -7,7 +7,7 @@
- ## Installation paths
- ##
+@@ -8,7 +8,7 @@
  
+ # Installation path prefix. Unless you know what you're doing, the default
+ # of /usr/local is likely the correct choice.
 -PREFIX=/usr/local
 +PREFIX=/usr
  
  # Unless you are creating a package conforming to some OS's standards, you
  # probably do not want to modify the following directories:
-@@ -15,7 +15,7 @@
+@@ -16,7 +16,7 @@
  # Main binaries
  BINDIR=$(PREFIX)/bin
  # Configuration .lua files
@@ -18,7 +18,7 @@
  # Some .lua files and ion-* shell scripts
  SHAREDIR=$(PREFIX)/share/ion3
  # Manual pages
-@@ -27,11 +27,11 @@
+@@ -28,11 +28,11 @@
  # Nothing at the moment
  LIBDIR=$(PREFIX)/lib
  # Modules
@@ -32,7 +32,7 @@
  # For ion-completeman system-wide cache
  VARDIR=/var/cache/ion3
  # Message catalogs
-@@ -56,18 +56,18 @@
+@@ -59,18 +59,18 @@
  
  # If you have installed Lua 5.1 from the official tarball without changing
  # paths, this should do it.
  
  
  ##
-@@ -104,7 +104,7 @@
- # asprintf and vasprintf in the c library. (gnu libc has.)
- # If HAS_SYSTEM_ASPRINTF is not defined, an implementation
- # in sprintf_2.2/ is used.
+@@ -124,7 +124,7 @@
+ # You may uncomment this if you know that your system C libary provides
+ # asprintf and  vasprintf. (GNU libc does.) If HAS_SYSTEM_ASPRINTF is not
+ # defined, an implementation provided in libtu/sprintf_2.2/ is used. 
 -#HAS_SYSTEM_ASPRINTF=1
 +HAS_SYSTEM_ASPRINTF=1
  
- # If you're on an archaic system (such as relatively recent *BSD releases)
- # without even dummy multibyte/widechar and localisation support, you may 
-@@ -140,14 +140,14 @@
+ # The following setting is needed with GNU libc for clock_gettime and the
+ # monotonic clock. Other systems may not need it, or may not provide a
+@@ -163,14 +163,14 @@
  
  #C89_SOURCE=-ansi
  
  
  # The -DCF_HAS_VA_COPY option should allow for some optimisations, and 
  # in some cases simply defining
+--- ion3.orig/utils/ion-statusd/Makefile
++++ ion3/utils/ion-statusd/Makefile
+@@ -15,7 +15,7 @@
+ DEFINES += -DETCDIR=\"$(ETCDIR)\" -DSHAREDIR=\"$(SHAREDIR)\" \
+            -DEXTRABINDIR=\"$(EXTRABINDIR)\" -DMODULEDIR=\"$(MODULEDIR)\" \
+          -DLCDIR=\"$(LCDIR)\" -DLOCALEDIR=\"$(LOCALEDIR)\" \
+-           -DSTATUSD_LOCATION=\"$(EXTRABINDIR)/ion-statusd\"
++#           -DSTATUSD_LOCATION=\"$(EXTRABINDIR)/ion-statusd\"
+            
+ SOURCES = ion-statusd.c exec.c extlrx.c