]> git.decadent.org.uk Git - emusic-remote.git/blobdiff - debian/rules
Removed executable permission from non-executable files.
[emusic-remote.git] / debian / rules
index e26014d70305c7cda784043c7aa425273081f977..4119776f3001b256a2ccccad0b21414ec917a91f 100755 (executable)
@@ -1,8 +1,6 @@
 #!/usr/bin/make -f
 
-build: build-stamp
-build-stamp:
-       touch $@
+build:
 
 clean:
        dh_testdir
@@ -14,17 +12,16 @@ install: build
        dh_testdir
        dh_testroot
        dh_clean -k 
-       #dh_installdirs
+       dh_install
+       find debian/emusic-remote/usr/share/emusic-remote -type f \
+       | xargs chmod -x
 
-# Build architecture-independent files here.
 binary-indep: install
        dh_testdir
        dh_testroot
        dh_installchangelogs 
        dh_installdocs
-       dh_install
        dh_installmenu
-       dh_installman
        dh_compress
        dh_fixperms
        dh_installdeb
@@ -32,7 +29,6 @@ binary-indep: install
        dh_md5sums
        dh_builddeb
 
-# Build architecture-dependent files here.
 binary-arch:
 
 binary: binary-indep binary-arch