]> git.decadent.org.uk Git - emusic-remote.git/blobdiff - debian/rules
[svn-inject] Applying Debian modifications to trunk
[emusic-remote.git] / debian / rules
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..e26014d
--- /dev/null
@@ -0,0 +1,39 @@
+#!/usr/bin/make -f
+
+build: build-stamp
+build-stamp:
+       touch $@
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp
+       dh_clean 
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k 
+       #dh_installdirs
+
+# Build architecture-independent files here.
+binary-indep: install
+       dh_testdir
+       dh_testroot
+       dh_installchangelogs 
+       dh_installdocs
+       dh_install
+       dh_installmenu
+       dh_installman
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+# Build architecture-dependent files here.
+binary-arch:
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install