]> git.decadent.org.uk Git - ion3.git/blobdiff - debian/patches/205_ion-lock.diff
Merge commit '20081002' into HEAD
[ion3.git] / debian / patches / 205_ion-lock.diff
index 6d2dfafa265d6467530b9cd1556b414994d60821..70de7237ba17b9be16c71421cd84058d013526f5 100755 (executable)
@@ -1,7 +1,19 @@
+--- ion3.orig/etc/cfg_ioncore.lua
++++ ion3/etc/cfg_ioncore.lua
+@@ -330,7 +330,8 @@
+ defmenu("mainmenu", {
+     menuentry("Run...",         "mod_query.query_exec(_)"),
+     menuentry("Terminal",       "ioncore.exec_on(_, XTERM or 'xterm')"),
+-    menuentry("Lock screen",    "ioncore.exec_on(_, 'xlock')"),
++    menuentry("Lock screen",
++              "ioncore.exec_on(_, ioncore.lookup_script('ion-lock'))"),
+     menuentry("Help",           "mod_query.query_man(_)"),
+     menuentry("About Ion",      "mod_query.show_about_ion(_)"),
+     submenu("Styles",           "stylemenu"),
 --- ion3.orig/utils/Makefile
 +++ ion3/utils/Makefile
 @@ -11,7 +11,7 @@
- SUBDIRS=ion-completefile
+ SUBDIRS=ion-completefile ion-statusd
  INSTALL_SUBDIRS=$(SUBDIRS)
  
 -SHELLSCRIPTS = ion-runinxterm ion-completeman
@@ -9,7 +21,7 @@
  
  TARGETS = ion-completeman
  
---- ion3.orig/utils/ion-lock
+--- /dev/null
 +++ ion3/utils/ion-lock
 @@ -0,0 +1,6 @@
 +#!/bin/sh