]> git.decadent.org.uk Git - ion3.git/blobdiff - debian/patches/201_fix-paths.diff
Renamed patch to more accurate name.
[ion3.git] / debian / patches / 201_fix-paths.diff
diff --git a/debian/patches/201_fix-paths.diff b/debian/patches/201_fix-paths.diff
deleted file mode 100755 (executable)
index 6a3ce86..0000000
+++ /dev/null
@@ -1,89 +0,0 @@
---- ion3.orig/system.mk
-+++ ion3/system.mk
-@@ -7,7 +7,7 @@
- ## Installation paths
- ##
--PREFIX=/usr/local
-+PREFIX=/usr
- # Unless you are creating a package conforming to some OS's standards, you
- # probably do not want to modify the following directories:
-@@ -15,7 +15,7 @@
- # Main binaries
- BINDIR=$(PREFIX)/bin
- # Configuration .lua files
--ETCDIR=$(PREFIX)/etc/ion3
-+ETCDIR=/etc/X11/ion3
- # Some .lua files and ion-* shell scripts
- SHAREDIR=$(PREFIX)/share/ion3
- # Manual pages
-@@ -27,11 +27,11 @@
- # Nothing at the moment
- LIBDIR=$(PREFIX)/lib
- # Modules
--MODULEDIR=$(LIBDIR)/ion3/mod
-+MODULEDIR=$(LIBDIR)/ion3
- # Compiled Lua source code
- LCDIR=$(LIBDIR)/ion3/lc
- # ion-completefile (does not belong in SHAREDIR being a binary file)
--EXTRABINDIR=$(LIBDIR)/ion3/bin
-+EXTRABINDIR=$(LIBDIR)/ion3
- # For ion-completeman system-wide cache
- VARDIR=/var/cache/ion3
- # Message catalogs
-@@ -56,18 +56,18 @@
- # If you have installed Lua 5.1 from the official tarball without changing
- # paths, this should do it.
--LUA_DIR=/usr/local
--LUA_LIBS = -L$(LUA_DIR)/lib -llua
--LUA_INCLUDES = -I$(LUA_DIR)/include
--LUA=$(LUA_DIR)/bin/lua
--LUAC=$(LUA_DIR)/bin/luac
-+#LUA_DIR=/usr/local
-+#LUA_LIBS = -L$(LUA_DIR)/lib -llua
-+#LUA_INCLUDES = -I$(LUA_DIR)/include
-+#LUA=$(LUA_DIR)/bin/lua
-+#LUAC=$(LUA_DIR)/bin/luac
- # If you are using the Debian packages, the following settings should be
- # what you want.
--#LUA_LIBS=`pkg-config --libs lua5.1`
--#LUA_INCLUDES=`pkg-config --cflags lua5.1`
--#LUA=/usr/bin/lua5.1
--#LUAC=/usr/bin/luac5.1
-+LUA_LIBS=`pkg-config --libs lua5.1`
-+LUA_INCLUDES=`pkg-config --cflags lua5.1`
-+LUA=`which lua5.1`
-+LUAC=`which luac5.1`
- ##
-@@ -104,7 +104,7 @@
- # asprintf and vasprintf in the c library. (gnu libc has.)
- # If HAS_SYSTEM_ASPRINTF is not defined, an implementation
- # in sprintf_2.2/ is used.
--#HAS_SYSTEM_ASPRINTF=1
-+HAS_SYSTEM_ASPRINTF=1
- # If you're on an archaic system (such as relatively recent *BSD releases)
- # without even dummy multibyte/widechar and localisation support, you may 
-@@ -140,14 +140,14 @@
- #C89_SOURCE=-ansi
--#POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
-+POSIX_SOURCE=-D_POSIX_C_SOURCE=200112L
- # Most systems
--#XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
-+XOPEN_SOURCE=-D_XOPEN_SOURCE -D_XOPEN_SOURCE_EXTENDED
- # SunOS, (Irix)
- #XOPEN_SOURCE=-D__EXTENSIONS__
--#C99_SOURCE=-std=c99 -DCF_HAS_VA_COPY
-+C99_SOURCE=-std=c99 -DCF_HAS_VA_COPY
- # The -DCF_HAS_VA_COPY option should allow for some optimisations, and 
- # in some cases simply defining