]> git.decadent.org.uk Git - nfs-utils.git/commitdiff
Import Debian version 1:1.2.8-9 debian/1%1.2.8-9
authorBen Hutchings <ben@decadent.org.uk>
Fri, 11 Mar 2016 04:04:46 +0000 (04:04 +0000)
committerBen Hutchings <ben@decadent.org.uk>
Fri, 11 Mar 2016 04:04:46 +0000 (04:04 +0000)
debian/changelog
debian/patches/22-mountd-fix-segfault-in-add_name-with-newer-gcc-compi.patch [new file with mode: 0644]
debian/patches/series

index 7df8fa01729d3746c26863f806f265a630ef1dd8..c00a73597c0c8b4545b38272497b17e61de4fdf3 100644 (file)
@@ -1,3 +1,11 @@
+nfs-utils (1:1.2.8-9) unstable; urgency=medium
+
+  * debian/patches/22-mountd-fix-segfault-in-add_name-with-newer-gcc-
+    compi.patch: cherry-pick fix from upstream for a segfault in 
+    add_name with newer gcc compilers.  Closes: #757835, LP: #1355829.
+
+ -- Steve Langasek <vorlon@debian.org>  Tue, 12 Aug 2014 17:12:38 -0700
+
 nfs-utils (1:1.2.8-8) unstable; urgency=medium
 
   * Upload to unstable where this belongs.
diff --git a/debian/patches/22-mountd-fix-segfault-in-add_name-with-newer-gcc-compi.patch b/debian/patches/22-mountd-fix-segfault-in-add_name-with-newer-gcc-compi.patch
new file mode 100644 (file)
index 0000000..a2ea91b
--- /dev/null
@@ -0,0 +1,63 @@
+From 8b03fdbfb0dd8e0147aa61ff30b8311235caf5f3 Mon Sep 17 00:00:00 2001
+From: Jeff Layton <jlayton@poochiereds.net>
+Date: Thu, 1 May 2014 11:15:16 -0400
+Subject: [PATCH] mountd: fix segfault in add_name with newer gcc compilers
+Bug-Debian: http://bugs.debian.org/757835
+Bug-Ubuntu: https://bugs.launchpad.net/ubuntu/+bug/1355829
+
+I hit a segfault in add_name with a mountd built with gcc-4.9.0. Some
+NULL pointer checks got reordered such that a pointer was dereferenced
+before checking to see whether it was NULL. The problem was due to
+nfs-utils relying on undefined behavior, which tricked gcc into assuming
+that the pointer would never be NULL.
+
+At first I assumed that this was a compiler bug, but Jakub Jelinek and
+Jeff Law pointed out:
+
+"If old is NULL, then:
+
+       strncpy(new, old, cp-old);
+
+is undefined behavior (even when cp == old == NULL in that case),
+therefore gcc assumes that old is never NULL, as otherwise it would be
+invalid.
+
+Just guard
+       strncpy(new, old, cp-old);
+       new[cp-old] = 0;
+with if (old) { ... }."
+
+This patch does that. If old is NULL though, then we still need to
+ensure that new is NULL terminated, lest the subsequent strcats walk off
+the end of it.
+
+Cc: Jeff Law <law@redhat.com>
+Cc: Jakub Jelinek <jakub@redhat.com>
+Signed-off-by: Jeff Layton <jlayton@poochiereds.net>
+Signed-off-by: Steve Dickson <steved@redhat.com>
+---
+ support/export/client.c | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/support/export/client.c b/support/export/client.c
+index ba2db8f..e749cac 100644
+--- a/support/export/client.c
++++ b/support/export/client.c
+@@ -482,8 +482,12 @@ add_name(char *old, const char *add)
+               else
+                       cp = cp + strlen(cp);
+       }
+-      strncpy(new, old, cp-old);
+-      new[cp-old] = 0;
++      if (old) {
++              strncpy(new, old, cp-old);
++              new[cp-old] = 0;
++      } else {
++              new[0] = 0;
++      }
+       if (cp != old && !*cp)
+               strcat(new, ",");
+       strcat(new, add);
+-- 
+2.1.0.rc1
+
index bf91ce03e2712d55dd1afc919d08728199f65994..8c74c7851901c816ee8a79054eb1093c429a1ab4 100644 (file)
@@ -7,3 +7,4 @@
 17-multiarch-kerberos-paths.patch
 19-iscsiadm-path.patch
 20-remove-autogenerated-man.patch
+22-mountd-fix-segfault-in-add_name-with-newer-gcc-compi.patch